Un sitio para guardar lo que veo, hago, y lo que quisiera ver, hacer y aprender.

Mensajes etiquetados Linux

NAS en problemas

Bueno, el NAS que compré funciona en forma admirable, todo bien excepto por el detalle de los discos que trae: Seagate. Así que no faltó mucho para que fallara uno de ellos, con lo que comenzó a enviar una serie de mensajes acerca de ello, y de la integridad de la información. Afortunadamente la solución aparece en la misma página de ayuda de Iomega, y es tan simple como reemplazar el disco dañado. Afortunadamente estos ya no son tan caros como hace un tiempo, y por supuesto adquirí un disco WD, ecológico, y que produce menos calor, con lo que el equipo se mantiene más fresco. Tan simple como remover un par de tornillos, sacar el disco dañado, poner el nuevo, reponer los tornillos y reiniciar el equipo. Automáticamente formatea y reconstruye la estructura de datos en espejo con lo que todo queda solucionado.

Chan, chan!

Virtual Box

Nueva version, o más bien mejoramiento de la version actual del programa que uso para mantener este servidor virtual. El problema es que sin decir agua va me cambian la forma de crear los módulos adecuados a cada kernel, así, lo que antes se hacía directamente con el daemon (sudo /etc/rc.d/vboxdrv setup), ahora va del siguiente modo:

actualizando virtualbox
*** To recompile the modules do /usr/bin/vboxbuild ***

Valorrrr….

Actualizacion de Kernel.

Al kernel 3.0

Estará apagado un rato, hasta rehacer los módulos de VirtualBox.

Listo… pase un poco de susto, ya que al recompilar los modulos, no quería iniciar la máquina virtual, pero reinicié todo el sistema y finalmente funcionó.

[mofeta@pluton ~]$ uname -r
3.0-ARCH

Problema de locales

Acabo de hacer una instalación completa de Arch en un pendrive de 4GB, con Xfce4 como escritorio… bien, rápido, luego de solucionar algunos ‘inconvenientes’ como el tener el escritorio en inglés porque las variables de locales no están bien. Cada vez que las muestro con locale me muestra que son "POSIX". La solucion fué editar el archivo /etc/enviroment y poner lo siguiente:

LANG=”es_CL.UTF-8″
LC_ALL=”es_CL.UTF-8″

Y listo.
Lo otro es crear un archivo que se ejecute cada vez que inicia Xfce4 y poner en él:

synclient VertEdgeScroll=1
synclient VertTwoFingerScroll=0
synclient TapButton2=3
synclient TapButton3=2

Para poder tener la usabilidad de mi trackpad del modo que llevo años usándolo, tap con dos dedos equivale al boton derecho, scroll vertical usando el borde derecho para mayor precisión.

Gran Cambio

Cambio, cambio. El finde largo me dediqué a eliminar Ubuntu 10.10 de mi sistema e instalar Archlinux. No fué difícil la tarea, lo difícil fue decidirme a formatear todo el disco donde tenía mis torrent, pero al final lo hice, de modo que la cosa quedó del modo siguiente:

sda de 1TB, con Archlinux completo, root (50GB), swap (2GB) y el resto de home. El disco de 500GB que aun contiene a Ubuntu, está desenchufado y pretendo dejarlo de respaldo, o en su defecto para almacenar los torrent, ya veremos.

Si bien la instalación de Arch no es dificultosa y ya la he hecho unas tres veces en mis netbook, no está excenta de algunos problemas, más que nada de configuración, o compatibilidad de hardware.

LEER MÁS »

Flicker

Parpadeo.

Eso es lo que le pasa al monitor desde… ya no recuerdo despues de qué es que hace eso. Generalmente cuando está conectado a la corriente eléctrica, y se ajusta el brillo del monitor. Para detenerlo simplemente modificaba el volumen (apareciendo los íconos respectivos para demostrar la acción en pantalla) y listo.

Traté con diversos métodos, y al parecer tiene relación con gnome-power-manager, por lo que lo eliminé. Pero ya no me funcionaba el suspender cuando cerraba la tapa, el botón de apagado, etc, etc…

Probé a usar xfce4-power-manager y después de tratar de que se lanzara cuando inciaba gnome (hay que hacer ejecutable el archivo .desktop respectivo que está en ~/.config/autostart), me di cuenta de que también pasaba lo mismo. Menos seguido pero igual.

Ahora volví al gnome-power-manager, pero agregué i915.powersave=0 al final de la línea ‘kernel’ del archivo menu.list de /boot/grub/ y eliminé vga=771. A ver que pasa ahora.

Tips perdidos

Eso… se me perdieron algunos tips en el disco anterior.

Como el agregar un nuevo usuario a la base de datos de mysql:

grant all privileges on *.* to 'user'@'localhost' identified by 'password' with grant option;

Eso… agregaré más segun las recuerde.

Nuevo Servidor ?

Creo que voy a tener que pasarme en definitiva a Arch.

El fallo que se me presenta en el equipo, que se corrompe el sistema de archivos del disco “/” y ahora hice una actualización del servidor virtual (usa Ubuntu LTS), tiene los paquetes de PHP5 vinculados a apache, por lo que cada vez que se actualizan, reinstala Apache2 y como yo uso Lighttpd como servidor web, pues me crea serios conflictos, así que tengo que acordarme que se reinstaló apache, desinstalar y borrar la configuracion de apache, para poder luego reiniciar lighttpd y que todo vuelva a lo normal.

No es chiste.

Mi Archlinux

Como tengo una entrada destacando el escritorio de Maverk Meerkat, me encargo ahora de poner una de mi escritorio actual de mi netbook, usando ya archlinux. Me cambié definitivamente de ubuntu a algo más liviano y personalizable. Ubuntu se está comenzando a parecer algo a Microsoft, creando soluciones personales, que funcionan bien y a la primera en Ubuntu, pero son difíciles de trasladar a otras versiones de linux, o, usan archivos de configuracion no estandard, o ubicados en lugares no habituales. LEER MÁS »

Oops!

Nuevamente mi PC me hace una mala jugada, y se muere durante mis vacaciones, por lo que recién pude repararlo, pero desafortunadamente la imagen del servidor virtual se corrompe irreparablemente, por lo que tuve que restablecer un respaldo de Noviembre del año 2010,así que se me perdieron algunas entradas. Tengo que recordar respaldar más seguido este asunto.